1. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
    So no guages working.,no instrument lights.2005 mini s?after checking wiring harness and plugging it back in upside down the airbag blew my headlights out..?now I have no headlights and lost power tomaybe 5 fuses ...not sure what to troubleshoot
     
  2. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member Supporting Member

    Jul 31, 2009
    9,279
    4,976
    113
    Male
    Ratings:
    +5,522 / 5 / -0
    You may have done quite a bit of damage. Let me make sure I understand what happened. When you were working on your mini was the battery still connected? So when you tried to plug the harness back in the airbag blew because you had the harness plug upside-down.
    If this is what happened you have set off the immobilizer. Off the top of my head I don't remember how to reset in. Someone els here may know, I can check later today after work. You may check your battery there is a Fuse module at the battery that may be blown. Are you getting any power? Its #2 below. If you are getting power what codes is it showing. I hope you didn't fry your ECU or BCM

    Screen Shot 2019-02-21 at 1.23.35 PM.png
     
  3. Minidave

    Minidave Well-Known Member
    Lifetime Supporter

    Dec 22, 2009
    4,801
    2,446
    113
    Male
    Overland Park, Ks
    Ratings:
    +2,569 / 1 / -0
    I really thought all these plugs were one way? Seems like you'd have to really force it to get it in backwards.....
     
    • Agree Agree x 2
    • Like Like x 1
    • List
  4. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
    Yeah that's pretty much right.the battery was still connected.going to check fuse .thanks,
     
  5. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
    O and on the connector the plastic piece was off.probably on there to keep from hooking up wrong$..with it off I could get a better look at corrison.just forgot to unhook battery#1
     
  6. wmwny

    wmwny Well-Known Member

    May 29, 2009
    3,528
    1,767
    113
    Retired
    Piqua, Ohio
    Ratings:
    +1,949 / 2 / -0
    Welcome to M/A!
     
  7. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
  8. wmwny

    wmwny Well-Known Member

    May 29, 2009
    3,528
    1,767
    113
    Retired
    Piqua, Ohio
    Ratings:
    +1,949 / 2 / -0
    You're welcome. I'm not mechanically oriented, but there are lots of people here who can and will try to help. That said, Welcome to Motoring Alliance and Good Luck!
     
  9. Goldsmithy

    Goldsmithy MINI Alliance Ambassador
    Articles Moderator Supporting Member

    Jan 30, 2015
    1,748
    982
    113
    Male
    TCB
    Main Street in the land of Oz
    Ratings:
    +1,151 / 0 / -0
    Welcome to M/A. The one thing I can offer is moral support. GOOD LUCK with your problem and we are here to help.
     
  10. Sully

    Sully Administrator
    Staff Member Articles Moderator

    Jul 21, 2015
    1,970
    822
    113
    Software
    30350
    Ratings:
    +951 / 8 / -0
    What did you find?
     
  11. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
    Well it will start and run ok,so i must be getting power from battery.im just wondering what to do.kinda feels like brakes are engaged alittle.still no lights.
     
  12. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member Supporting Member

    Jul 31, 2009
    9,279
    4,976
    113
    Male
    Ratings:
    +5,522 / 5 / -0
    Did you check all your fuses?
     
  13. Rock bake

    Rock bake New Member

    Feb 19, 2019
    6
    1
    3
    Ratings:
    +1 / 0 / -0
    Yes. There are maybe four fuses that are good but have no power.not sure how to check a relay?
     

Share This Page