ABS, DSC, TPMS

Discussion in 'Mid-Ohio Motoring' started by mergemini, Apr 7, 2013.

Tags:
  1. mergemini

    mergemini New Member

    Nov 11, 2010
    304
    71
    0
    Creative Director
    Latest stop, Columbus, OH
    Ratings:
    +71 / 0 / -0
    Ok, another question about my R50.

    I noticed that NONE of these lights come on. They don't even light up when I start the car. I initially noticed when I tried to deactivate the DSC and couldn't get a light to come on.

    Then, when I attempted to replace the speedo, I noticed that the lights DID come on through the new speedo.

    I took my speedo apart to see if there was some tampering with bulbs, but I could not see how that was even possible.

    I know the potential solve is the wheel speed sensors, but I'm curious if anyone has any idea why the lights aren't lighting up.

    With this amazing weather, I obviously can't check to see if the ABS or DSC actually works.

    Alright, discuss...
     
  2. Crashton

    Crashton Club Coordinator

    Jun 4, 2009
    19,125
    9,668
    113
    Retired old fart
    Hooterville Ohio USA
    Ratings:
    +10,998 / 2 / -0
    #2 Crashton, Apr 7, 2013
    Last edited: Apr 7, 2013
    Find an empty lot get going say 40 or so & stand on the brakes. You will know if the ABS is working.

    Take a look & see if there is a fuse for the abs/dsc. Not sure if there is or not.
     
  3. mergemini

    mergemini New Member

    Nov 11, 2010
    304
    71
    0
    Creative Director
    Latest stop, Columbus, OH
    Ratings:
    +71 / 0 / -0
    Ha. Maybe I will!

    Can't be a fuse if it came on in the other speedo, right?
     
  4. Nathan

    Nathan Founder

    Mar 30, 2009
    25,144
    10,033
    113
    Writer
    Short North
    Ratings:
    +10,050 / 0 / -0
    If Speedo A has no lights and Speedo B does it is the Speedo, not the fuse.

    I'd be checking with MAG or Anson over at John Best on how to get the Speedo that does light up to be programmed for use.
     
  5. Crashton

    Crashton Club Coordinator

    Jun 4, 2009
    19,125
    9,668
    113
    Retired old fart
    Hooterville Ohio USA
    Ratings:
    +10,998 / 2 / -0
    Yes Anson or John should be able to help you. Still go out & try the ABS. :ihih:
     
  6. ScottinBend

    ScottinBend Space Cowboy
    Supporting Member

    May 4, 2009
    8,743
    2,522
    113
    Bend, OR USA
    Ratings:
    +2,631 / 1 / -0
    But this is an R50.....we all know you can't go fast enough in an R50 to activate the ABS.

    Sheesh........:biggrin5:
     
  7. beaner

    beaner New Member

    May 5, 2009
    272
    44
    0
    Ratings:
    +44 / 0 / -0
    Ouch! that was mean......funny, but mean.:wink:
     
  8. mergemini

    mergemini New Member

    Nov 11, 2010
    304
    71
    0
    Creative Director
    Latest stop, Columbus, OH
    Ratings:
    +71 / 0 / -0
    Tell me about it!! What a difference from my R56. Amazing how differently it forces me to drive! Good news is it's my sons first car, so the lack of power is PERFECT! :Thumbsup:
     

Share This Page