1st Gen R50 Advice needed

Discussion in 'Tip's, Tricks and How To Articles' started by Brian connelly, Mar 1, 2021.

  1. Brian connelly

    Brian connelly New Member

    Mar 1, 2021
    4
    1
    1
    Male
    Ratings:
    +1 / 0 / -0
    Hi allnew to the forum and looking for advice !
    Got a mini one 2005 and love it deeply. However been having recent problems with it

    Firstly I've just done the head gasket on it took my time and followed to the letter also had the head machined before replacing it back on. I've got an over heat issue I've bled the system with all going well fluid showing on the bleed screws I've also replaced the thermostat and gasket. The coolant is bubbling in the expansion tank until it pops open from what I gather there seems no fluid only steam in the upper rad hose at the bleeder when the engine comes up to temp. I took it out a few miles today driving fine temp gauge at half way as normal. Stopped at lights and up she blows !

    Top rad hose is very hot bottom is cold my next thought is water pump? New radiator? Any advice would be much appreciated been at this for weeks now and miss driving her
     
  2. Crashton

    Crashton Club Coordinator

    Jun 4, 2009
    19,096
    9,642
    113
    Retired old fart
    Hooterville Ohio USA
    Ratings:
    +10,936 / 2 / -0
    Welcome to M/A Brian.

    Are the cooling fans coming on? Seems your MINI is running cool with airflow through the rad. Once you are stopped with no airflow the temp goes up. Makes me wonder if the cooling fans are working.

    Good luck.
     
  3. Brian connelly

    Brian connelly New Member

    Mar 1, 2021
    4
    1
    1
    Male
    Ratings:
    +1 / 0 / -0
    Yes fans are comming on when they should and the temp gauge does not go over half way
     
  4. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    10,369
    5,625
    113
    Male
    Ratings:
    +6,849 / 9 / -3
    Welcome to MA. we don’t get MINI ones here, wish we did! To bleed my R53 completely I had to open the bleed screw and turn the heater on high then let it warm up till the thermostat opened. Then I would add more antifreeze till it came out the bleed screw. If you did not have the heat on you could still have air in the system. Although you did say the top hose is getting hot, that sounds like it is circulating coolant.
    You say coolant is bubbling in the expansion tank, this could be a sign that you are getting combustion gas in your cooling system. Did you have your head checked to make sure it was flat before changing the gasket?
     
  5. Brian connelly

    Brian connelly New Member

    Mar 1, 2021
    4
    1
    1
    Male
    Ratings:
    +1 / 0 / -0
    Yes head was machined prior to replacement also all bleed processes was done sorry for posting about a mini one will try find another info source was just asking becuse I'm struggling with it just now
     
  6. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    10,369
    5,625
    113
    Male
    Ratings:
    +6,849 / 9 / -3
    Please don’t be sorry! We are glad to have you here.
     
  7. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    10,369
    5,625
    113
    Male
    Ratings:
    +6,849 / 9 / -3
  8. 00Mini

    00Mini Well-Known Member

    Feb 24, 2013
    15,948
    754
    113
    Retired
    Ratings:
    +1,178 / 5 / -3
    Welcome to Motoring Alliance
     
  9. Brian connelly

    Brian connelly New Member

    Mar 1, 2021
    4
    1
    1
    Male
    Ratings:
    +1 / 0 / -0
    Thanks all will close the post soon replacing the radiator water pump and matrix will up date soon
     
  10. 00Mini

    00Mini Well-Known Member

    Feb 24, 2013
    15,948
    754
    113
    Retired
    Ratings:
    +1,178 / 5 / -3
    Look forward to hearing that you have corrected the problem and how you did it.
     

Share This Page