1st Gen R53 Cooper S Engine light help

Discussion in '1st Generation: 2002–06 R50, R53 & 2004–08 R52' started by lr19, Aug 12, 2016.

  1. lr19

    lr19 New Member

    Aug 12, 2016
    54
    0
    0
    Ratings:
    +0 / 0 / -0
    Have a 04 cooper S engine light can on last week had the code read was told most likes gap cap, so bought a new one engine light still on ? Was told it was a soft code so should go away on its own, anyone else ever had this issue?


    Sent from my iPhone using Tapatalk
     
  2. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    11,184
    6,182
    113
    Male
    Ratings:
    +7,903 / 10 / -3
    Did you have them clear it? I have had it and I had to clear it to make it go away. Also is it a OEM cap?
     
  3. lr19

    lr19 New Member

    Aug 12, 2016
    54
    0
    0
    Ratings:
    +0 / 0 / -0
    No they didn't guy told me it would go away, and not oem got at advance was the more expensive of the two they had, should I go ahead and pull the negative to clear it and see what happens?


    Sent from my iPhone using Tapatalk
     
  4. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    11,184
    6,182
    113
    Male
    Ratings:
    +7,903 / 10 / -3
    Yea I would. As I said mine would not clear on its own. Also I just took my cap off and put it back on and have not had a problem sense. Let us know what happens.
     
  5. lr19

    lr19 New Member

    Aug 12, 2016
    54
    0
    0
    Ratings:
    +0 / 0 / -0
    Will do, I'll pull the cable tmmrw, I'm not sure about your cap but my original oem cap was rough, the seal part was very dry rotted looking so that's why I went ahead and got a new one, thanks for advice will keep posted


    Sent from my iPhone using Tapatalk
     
  6. lr19

    lr19 New Member

    Aug 12, 2016
    54
    0
    0
    Ratings:
    +0 / 0 / -0
    Update before I had a chance to pull my battery cable the engine light shut off on its own!


    Sent from my iPhone using Tapatalk
     
  7. 00Mini

    00Mini Well-Known Member

    Feb 24, 2013
    21,139
    2,073
    113
    Retired
    Ratings:
    +3,047 / 6 / -5
    Thanks for the update and good to hear your problem was corrected. :Thumbsup:
     

Share This Page