2nd Gen R55 Clubman Engine Stutter

Discussion in '2nd Generation: 2007+ R55 through R61' started by MOB, Nov 24, 2016.

  1. MOB

    MOB New Member

    Nov 1, 2016
    2
    0
    1
    Ratings:
    +0 / 0 / -0
    I have a 2008 R55 with 106k miles. Only MOD being a K&N CAI to replace the factory pipe which was cracked because the previous owner tightened the clamp to tight and I wanted to replace it with an aluminum pipe.

    The car has no CEL but when cruising around 2000 rpm, but when I apply a little throttle to the point where the car doesn't downshift or the rpm's don't climb but the CAI starts sucking massive air the car will stutter usually about 3 times before going back to normal. Doesn't seem to be an issue if I give it enough gas to make the motor revs up as well. Doesn't do it all the time but I can replicate the issue if I try.

    My only guess is that the MAF is going bad and the ECU can't apply the correct air to fuel ratio.

    I appreciate any advice. Happy Turkey Day

    Sent from my Pixel using Tapatalk
     
  2. Dave.0

    Dave.0 Helix & RMW Powered
    Lifetime Supporter

    May 4, 2009
    25,023
    13,491
    113
    Burbs of Philly, PA
    Ratings:
    +14,637 / 10 / -4
    Carbon build up, walnut blasting needed if it has not been done in 50K. Also only run 91 octane above if you can find it.
     
  3. MOB

    MOB New Member

    Nov 1, 2016
    2
    0
    1
    Ratings:
    +0 / 0 / -0
    Okay thanks for the advice. I have only run 91 since I bought the car 40k miles ago.

    Sent from my Pixel using Tapatalk
     
  4. Metalman

    Metalman Well-Known Member
    Lifetime Supporter

    Sep 29, 2009
    12,616
    7,518
    113
    Owner of a small custom metal fabrication company,
    Columbus, Ohio
    Ratings:
    +7,636 / 1 / -0
    If it is the "S", then David.0 is most likely correct with carbon buildup on the intake valves.... They can be cleaned with the walnut blast that doesn't damage the valves and it usually gets done around 50K or so.... Approximately $300.00 to have done...

    If your MINI is not an "S", then it's not carbon buildup but something else...
     
  5. 00Mini

    00Mini Well-Known Member

    Feb 24, 2013
    17,229
    1,050
    113
    Retired
    Ratings:
    +1,618 / 5 / -4
    Might be helpful to check for some diagnostic engine codes.
     
  6. cct1

    cct1 Well-Known Member
    Lifetime Supporter

    May 5, 2009
    3,378
    3,368
    113
    Ratings:
    +3,369 / 0 / -0
    Y-y-y-es. th-th-th-th-the st-st-stutter is m-m-m-most l-l-l-likely c-c-c-carbon b-b-buildup.
     
  7. ILive

    ILive New Member

    Nov 12, 2016
    7
    0
    1
    Ratings:
    +0 / 0 / -0
    Mine stutters also lately at 3rd or 4th at around high rpm, recently cleaned the sensors but I guess didn't change anything

    Sent from my QTAQZ3 using Tapatalk
     

Share This Page