Help!!! Battery terminal bolt broke

Discussion in 'MINI' started by siuformula, Sep 2, 2009.

  1. siuformula

    siuformula New Member

    Sep 1, 2009
    3
    0
    0
    Ratings:
    +0 / 0 / -0
    Sears replaced my batterry last june '08. I live in Florida and the factory battery from my '04 S made it just long enough for the warranty to run out. Sears was running a special so i had them put a new one in. last week when the car wouldn't start i popped the hatch and found a coral reef growing from my positive terminal. I took it back to sears and they told me that the battery was fine so they cleaned it up and recharged it. everything was fine they didn't even charge me a service fee. the car decided not to start yesterday when my wife had it. so i drove to her location and attempted to jump the car. Sears broke the T bolt on the clamp and apparently hammered it back on using a lead shim. I need to know if there is a better option or a replacement for that dumb T-bolt design that they use. has anyone else had an issue with Massive corrosion? I will try to post pics but i'm new to the forum and don't think i can.
     
  2. Nathan

    Nathan Founder

    Mar 30, 2009
    25,144
    10,033
    113
    Writer
    Short North
    Ratings:
    +10,050 / 0 / -0
  3. siuformula

    siuformula New Member

    Sep 1, 2009
    3
    0
    0
    Ratings:
    +0 / 0 / -0
    thanks I'll get some pics up soon and hopefully i can replace the clamp with something that can be purchased at a local parts store. I have searched high and low for the T-bolt and can't find one anywhere.
     
  4. goaljnky

    goaljnky New Member

    Apr 7, 2009
    3,105
    392
    0
    LaLaLand, Left Coast, Overpopulated and Underfunde
    Ratings:
    +392 / 0 / -0
    I busted mine long time ago in a fit of over-tightening. It actually did not take much to snap. My local SA was kind enough to find one for me at no charge. And no, I was not able to find one to buy and the parts department was trying to sell me the whole harness for about the price of a new car.
     
  5. Nathan

    Nathan Founder

    Mar 30, 2009
    25,144
    10,033
    113
    Writer
    Short North
    Ratings:
    +10,050 / 0 / -0
  6. siuformula

    siuformula New Member

    Sep 1, 2009
    3
    0
    0
    Ratings:
    +0 / 0 / -0
    I suppose that i could just get the neg side cable and since all i really need is the BOLT and it's about $300 CHEAPER!!!!:idea:

    Has anyone been brave enough to replace the factory clamp with something else?
     
  7. not-so-rednwhitecooper

    Aug 5, 2009
    40
    0
    0
    mechanic
    Chardon, Ohio
    Ratings:
    +0 / 0 / -0
    Cut it off, and replace it with a regular terminal connector. Autozone Has them on the shelf.
     

Share This Page