Interior 1st Gen HELP!!! Speedo Falls below 0... I want to fix it!

Discussion in 'Tuning and Performance' started by lairdlan, Sep 13, 2012.

Tags:
  1. lairdlan

    lairdlan New Member

    Sep 10, 2012
    9
    4
    0
    Ratings:
    +4 / 0 / -0
    My speedometer needle falls below the 0 mark. I have attached a photo to show you what i'm talking about.

    How can i get in there and fix it so that it reads the correct speed? It constantly reads 20mph below my actual speed. I can easily see how fast i'm actually going, but it is a rather large nuisance and i'd like to fix it if possible.

    Thanks in advance for your help!
     

    Attached Files:

  2. Nathan

    Nathan Founder

    Mar 30, 2009
    25,144
    10,032
    113
    Writer
    Short North
    Ratings:
    +10,049 / 0 / -0
    Pull the speedo cluster out, remove the face, pull the needle and recenter it.

    The real question is how did the needle fall in the first place?
     
  3. lairdlan

    lairdlan New Member

    Sep 10, 2012
    9
    4
    0
    Ratings:
    +4 / 0 / -0
    Done! Thank you sir for the advice!

    Honestly it was like that when i purchased it! I know that doesn't speak well for me checking the car out very well, but in my rush to check everything else i completely missed that little detail.

    But it appears to be all better now.
     
  4. mergemini

    mergemini New Member

    Nov 11, 2010
    304
    71
    0
    Creative Director
    Latest stop, Columbus, OH
    Ratings:
    +71 / 0 / -0
    I'm having the same issue. I took it apart and set it at zero, and it's dropping again. Is there a fix? Or do I need a new speedo cluster?
     

Share This Page