Pending Code: P0171

Discussion in '1st Generation: 2002–06 R50, R53 & 2004–08 R52' started by TATTRAT, Aug 25, 2020.

  1. TATTRAT

    TATTRAT Active Member
    Supporting Member

    Oct 10, 2010
    429
    240
    43
    Executive Chef
    NoVA/DC
    Ratings:
    +277 / 0 / -0
    Help needed: Pending code started as P0170, now P0171 after cleaning/oiling air filter. All lines are hooked up, nothing that jumps out as disconnected or leaking.

    Is it possible it just sucked some of the filter oil in and fouled a sensor?

    It hasn't thrown the code, just "Pending" on the ultra-gauge.

    Any input greatly appreciated!
     
  2. Dave.0

    Dave.0 Helix & RMW Powered
    Lifetime Supporter

    May 4, 2009
    25,023
    13,489
    113
    Burbs of Philly, PA
    Ratings:
    +14,634 / 10 / -4
    What year car do you have? Or 1st Gen R53 ( no MAF sensor) or R56 2nd Gen with MAF Sensor.


    Take the filter out and wash off some oil. People always over oil them that why I run them without oil.

    for 2nd Gen:
    With the key off wipe off the mass air flow sensor inside the intake by the filter a little bit.

    ‘Then put it all back together again, clear any codes and start and drive the car. The code may not go away ASAP, it could take 50+ miles if you scan gauge does not clear it for you.
     
  3. Dave.0

    Dave.0 Helix & RMW Powered
    Lifetime Supporter

    May 4, 2009
    25,023
    13,489
    113
    Burbs of Philly, PA
    Ratings:
    +14,634 / 10 / -4
    Sounds like to me you have vacuum leak somewhere when you were potting everything back together OR you stated the car while you were working on it BEFORE EVERYTHING was put back together.

    clear the codes and drive it to see if it comes back.
     
  4. TATTRAT

    TATTRAT Active Member
    Supporting Member

    Oct 10, 2010
    429
    240
    43
    Executive Chef
    NoVA/DC
    Ratings:
    +277 / 0 / -0

    1st gen, 06.
     
  5. TATTRAT

    TATTRAT Active Member
    Supporting Member

    Oct 10, 2010
    429
    240
    43
    Executive Chef
    NoVA/DC
    Ratings:
    +277 / 0 / -0
    It was on the lift while putting everything back together, only turned the key as far as the acc mode, never turned it over until all four wheels were back on the ground.

    I'll see if it will let me clear the codes. They haven't been thrown, just "pending", if that matters.
     
  6. Dave.0

    Dave.0 Helix & RMW Powered
    Lifetime Supporter

    May 4, 2009
    25,023
    13,489
    113
    Burbs of Philly, PA
    Ratings:
    +14,634 / 10 / -4
    Take it out for a good rip and maybe the code will clear itself or go to a fault code and not pending.
     
  7. TATTRAT

    TATTRAT Active Member
    Supporting Member

    Oct 10, 2010
    429
    240
    43
    Executive Chef
    NoVA/DC
    Ratings:
    +277 / 0 / -0

    Went to do that yesterday, never gave me an alarm. Guessing it's all squared away and just had to do with the new air filter.

    All is well in my MINI world.
     

Share This Page