Possible oil leak R56

Discussion in 'Tuning and Performance' started by usafpj13, Apr 2, 2021.

  1. usafpj13

    usafpj13 Member

    Feb 9, 2019
    43
    20
    8
    Ratings:
    +23 / 0 / -0
    Hi everybody. I just drove my R56 from Chicago to Las Vegas(2,000 miles) and used a little over a quart of oil to keep it topped up. That seems a bit high to me. I also had to add a little bit of coolant. Mileage was fine at about 33mpg. I'm going to change the oil in the next few days and will see what that looks like. I did just run seafoam through the PCV to air intake and got a lot of smoke out of the exhaust as expected but also got some from somewhere in the engine block(maybe the exhaust manifold) and also some out of the vents inside. I do have an oil catch can hooked up to the right side of the engine(as looking from the front of the car). There is also a burning plastic smell on startup from the air vents. It recently passed smog and runs well so I am thinking there is a small oil or air leak somewhere(Head gasket?). Any ideas?

    2010 Hardtop S 83,000 miles
     
  2. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    10,584
    5,759
    113
    Male
    Ratings:
    +7,120 / 9 / -3
    Did you have the smell before the SeaFoam? I believe you have an N14 engine. Take a good look at the valve cover they some times warp with time due to heat and leak
     
  3. usafpj13

    usafpj13 Member

    Feb 9, 2019
    43
    20
    8
    Ratings:
    +23 / 0 / -0
    I do have an N14 engine and have had the smell for years. A mechanic years ago said the smell was because I installed silicone intake pipes but it has not gone away. It isn't the valve cover. I replaced that about 3 years ago and it is not where the smoke was coming from.
     

Share This Page