R50 rough idle and limp mode

Discussion in '1st Generation: 2002–06 R50, R53 & 2004–08 R52' started by Delacruz25, Oct 15, 2020.

  1. Delacruz25

    Delacruz25 New Member

    Oct 15, 2020
    1
    0
    1
    Ratings:
    +0 / 0 / -0
    So I have an 05 MC and recently the car has had a rough idle. Morning cold starts are fine but once the car reaches operating temps, it starts to have this rough idle. I had two codes, P0302 and P0128. I changed the distributor cap, plugs and wires. Seemed like limp mode got worse. I’ll be sitting at a red light and check engine flashes and when I accelerate, it struggles to get going. I’m thinking it could be the crank pulley but need a second opinion.
     
  2. 00Mini

    00Mini Well-Known Member

    Feb 24, 2013
    15,420
    689
    113
    Retired
    Ratings:
    +996 / 3 / -0
    The first code is misfire on cylinder 2 and the second code is thermostat related. On the misfire I would check the coil and then if that was good a compression / leak down test. For the P0128 check the coolant level, thermostat housing and thermostat. I’m just an old shade tree mechanic and my knowledge is limited but those are the areas I would start. Hopefully it will be something easy and you’ll be up and running at full strength in no time.
     
    • Like Like x 1
    • Agree Agree x 1
    • List
  3. MCS02

    MCS02 Moderator
    Staff Member Articles Moderator Supporting Member

    Jul 31, 2009
    10,128
    5,467
    113
    Male
    Ratings:
    +6,568 / 9 / -3
    Welcome to MA!
     
    • Like Like x 1
    • Agree Agree x 1
    • List
  4. minsanity

    minsanity Well-Known Member

    Sep 11, 2009
    578
    341
    63
    Ratings:
    +366 / 0 / -0
    Check fuel rail pressure & coolant temp sensor. The former, if low, could be fuel filter or pump related

    Sent from my SM-G970F using Tapatalk
     

Share This Page