R53 Unsolved Mystery: DSC Toggle Off Turns SES On

Discussion in '1st Generation: 2002–06 R50, R53 & 2004–08 R52' started by minsanity, Aug 2, 2020.

  1. minsanity

    minsanity Well-Known Member

    Sep 11, 2009
    576
    338
    63
    Ratings:
    +362 / 0 / -0
    #1 minsanity, Aug 2, 2020
    Last edited: Aug 2, 2020
    Recently snagged a hobo used full toggle bank to complete my stock 02's incomplete 1 which doesn't have the rear fog of facelift R53s, but a reverse light.[​IMG][​IMG]
    The stock 1 worked fine, never had issues. The 'new' used is from an '06, I guess. 1 glitch I noted was the SES light turns on once DSC is toggled off. Engine doesn't skip a beat, no hiccups whatsoever.[​IMG] Once I toggle DSC back on, both lights go off.[​IMG]
    Any lead, explanation, or solution to the mystery would be much appreciated.

    Sent from my SM-G970F using Tapatalk
     
  2. Metalman

    Metalman Well-Known Member
    Lifetime Supporter

    Sep 29, 2009
    12,563
    7,446
    113
    Owner of a small custom metal fabrication company,
    Columbus, Ohio
    Ratings:
    +7,477 / 1 / -0
    Pretty sure it's going to require at trip to the dealer or independent that can program the ECM to know that there is now an operating switch where the blank was...

    Not a plug n play without some rearranging of some confuser bits & bytes...
     
  3. minsanity

    minsanity Well-Known Member

    Sep 11, 2009
    576
    338
    63
    Ratings:
    +362 / 0 / -0
    I could put the stock 1 back or stay w/ this & ignore the light. I highly doubt the dealership local to me would have the expected expertise to dig into this.

    Sent from my SM-G970F using Tapatalk
     

Share This Page